What Happened to Exchange Server 2010 SP2 Update Rollup 5?

A few weeks ago Microsoft released Update Rollup 5 for Exchange Server 2010 SP2 (link is currently not working, read on).

Normally these releases are accompanied by an announcement on the Exchange Team Blog, but this time there was no announcement, though plenty of MVPs and other bloggers immediately wrote about it.

Unfortunately it now appears there was a bug in this latest update. To the best of my knowledge this was first reported on Tony Redmond’s blog via a reader comment, prompting Tony to recommend that people do not deploy it.

DO NOT DEPLOY RU5. Microsoft has been informed about a bug that affects DAGs. DO NOT DEPLOY RU5 until the bug is fixed! This proves once again that you should never rush a roll-up update into production. Always test, test, and test again first…

Now it seems the update has been withdrawn completely. The download link no longer works, and a Microsoft PFE commented in the TechNet forums:

It was removed due to an issue with the update – sorry!

Due to the bugs, and the fact that the update is now withdrawn, if you happen to have downloaded it while it was still available the sensible course of action would be to not deploy it in your environment.

About Paul Cunningham

Paul is a Microsoft Exchange Server MVP and publisher of Exchange Server Pro. He also holds several Microsoft certifications including for Exchange Server 2007, 2010 and 2013. Connect with Paul on Twitter and Google+.

Comments

  1. Again? I reckon every single Update Rollup out of the last four has had a problem.

    I know they “test thoroughly” but this really doesn’t make me, as an Exchange admin, feel very comfortable with the product at the moment.

  2. I am hoping the rollup will resolve some issues with UM. Like having a “beep” after hearing someone’s personal greeting with call answering rules setup. This was scheduled to be released before but taken away and only available in 2013 from what I’ve heard from MS.

  3. Thats one more reason to wait before going to Exchange 2013. They didnt even have the time to fix 2010.

  4. Looks like Version 2 has been released:

    http://www.microsoft.com/en-us/download/details.aspx?id=36017

  5. After deploying roll up 5. something goes wrong with outlook connections.

    Any pointers ?

Leave a Comment

*

We are an Authorized DigiCert™ SSL Partner.